Jan 12 2011
By: mskrb2010 First Son 5 posts

Game-breaking glitch! Please help!

2 replies 471 views Edited Jan 12, 2011

Ok, so here's the deal. I got Uncharted 2 for Christmas and I freaking love it. However I can no longer proceed in the single player game. A couple weeks ago I reached Chapter 7 and went across the river with the cars and fought in that little area with the turret up the stairs. Afterwards I climbed up the blue piping on the side of the wall. From there the only place to go is across the railing at the bottom of the billboard. Below is the gray street with the guys and the tank that passes underneath you.


So the problem is, the building that's supposed to be there apparently is gone. Just a black space. When I walk to where the billboard-ledge is supposed to end and go to a window or whatever, I just fall down into the street near the trash pile thing, at the edge of the blackness. Nathan dies of course. So the screen fades to black and shows the Phurba dagger loading icon. Only it doesn't stop. I left it there for like 10 minutes and nothing. I've tried several times, and one time the music glitched so the same second was repeating, and once the music just didn't play I believe.


The game was bought used at Gamestop, and I updated to the latest software soon after, long before I reached Chapter 7. The spine of the case says:



Although I can't guarentee the disk matches the case originally, I assume so. It's very likely the disk is still the same version anyways I'd reckon so it shouldn't be a worry.


I haven't tried for about a week, maybe a bit more, but unless there was an update since then this should all be relevant, and it could be either way anyways.


Thanks for reading and I'd greatly appreciate it if someone would be able to help me! I really want to play this game some more. I'm not sure if I'll check this often so you can email me at if you don't mind. I'll be happy to take a picture of the void or provide more info if needed!


Edit: Oh, I guess it's worth mentioning that I have not had any other problems in the single player and multiplayer has worked flawlessly.

Message 1 of 3 (471 Views)
Keyblade Wielder
Registered: 10/11/2008
10163 posts

Thats really weird.  If you bought it at gamestop I'd tak...

Jan 12, 2011

Thats really weird.  If you bought it at gamestop I'd take it back and ask whats up. 

Message 2 of 3 (471 Views)
First Son
Registered: 03/24/2013
1 posts

Re: Game-breaking glitch! Please help!

[ Edited ]
Mar 24, 2013

Okay, it's a couple of years later, but I recently picked up a copy of Uncharted 2 brand new from a retail store. I have the same issue here.


I've spent hours thinking I'm missing something fundamental, only to die everytime, have the game crash (and subsequently, the console). The save game and auto save is broken as well, it just gets stuck on the loading screen, and I have to restart the chapter OVER and OVER.


I'm running this game on the newest PS3 super slim.


Here's a screenie of my experience (note black wall):



And here's a screenie taken from a game walkthrough site (note building in place of black wall):



This can't simply be a disc issue.... Surely there must be some resolution to this? Smiley Frustrated

Message 3 of 3 (464 Views)