Apr 03 2014
By: DawnBlue First Son 3 posts

DualShock 4 refuses all except in-box headset mic

1 replies 284 views Edited Apr 3, 2014

My DualShock 4 controllers are both refusing to work with any other headset than the crappy, 1 ear and a dangling microphone headset that I got from my PS4 box.


Specifically the problem is with the system not recognizing that I have a microphone plugged in. I have to try around 20 or more times, removing and re-inserting the jack from the controller, before I can get it to realize I have plugged in a headset instead of just a headphone.


I don't understand what could even be the cause of this problem. Every single headset I've tried with has a four-conductor 3.5 mm jack, they all are completely identical in shape (if they weren't I'd be somewhere else asking the manufacturer questions).


There is literally no visible difference between the headsets, yet no matter how many times I try the PS4's in-box headset, with crappy audio, 1 earpiece and a mediocre mic is recognized instantly every single time.  And every time I decide to use my Razer headset I have to waste up to 10 minutes in trying to make the OBVIOUSLY FAULTY IN DESIGN DualShock 4 realize I have a microphone, too.


If the problem was with a single headset, I'd ask it's manufacturer. If the problem was with a single DualShock 4, I'd replace it.


However, this problem persists across 2 DualShock 4 controllers, bought about 3 months between them, and across all headsets I have gotten my hands on in our house (at least 5different ones).

Message 1 of 2 (284 Views)
First Son
Registered: 12/18/2013
3 posts

Re: DualShock 4 refuses all except in-box headset mic

Sep 9, 2014

Almost created a new topic, but then I remembered I already tried to get some help. 

Message 2 of 2 (192 Views)