Mar 31 2013
By: raymondmoshe First Son 4 posts

I can't access the God Of War Ascension MP. help please

1 replies 239 views Edited Mar 31, 2013

 I've beaten single player mode, I tried to see if The Last of Us demo was available (which isn't...), and now when ever I try to launch the MP mode from the main menu, a screen keeps popping up with the following text:


"An Online Pass is required to play God of War: Ascension Multiplayer. Do you want to input an Online Pass?"


Before this started, I first redeemed my online pass from the PSN Store and downloaded it, then when I launched the game and proceed to launch MP, the screen pops up, I select 'Yes', I input the code just to see if I can still get into the MP even though I have already installed the online pass that came with the copy of the game I bought, I install it, go back to the main menu, try to launch MP again, the screen comes back, and rinse and repeat so far...


I have already tried to re-install the online pass through in-game, I tried to delete my GoW game data along with the patch (not my save file) and re-intall them, I have also tried to re-install the game through the PSN Store, and now I am out of options on what to do.


Is anyone here that can help me or knows how to solve my problem?

Message 1 of 2 (239 Views)
First Son
Registered: 02/06/2015
1 posts

Re: I can't access the God Of War Ascension MP. help please

Mar 15, 2015

hey even I need help with that.


I installed the network pass from psn store then go to multiplayer and select but the screen just pops up.

even I need help. I tried every other option BUT IT DOES NOT WORK GOD **bleep** IT!



I would really appreciate if anyone can help me.

Message 2 of 2 (138 Views)