Reply
Ghost of Sparta
Registered: 11/12/2010
Offline
9504 posts
 

Re: Didn't get Hub reward item today?

Nov 1, 2013
@AbysmalDawna the Spunland broom broom LMO was hidden in the Spunland Maze in the Store in The Spun O Ween version only. It has now switched back so I think you may have missed it.

To add to the conversation I as well did not get the Gothic Chair and I did not have it previously from the old Lockwood Showcase. It is the ONE item I still need from the set and I really hope I didnt miss it now for a second time -_-
Support Forums
Message 11 of 17 (221 Views)
Hekseville Citizen
Registered: 12/24/2011
Offline
254 posts
 

Re: Didn't get Hub reward item today?

Nov 1, 2013

smokingpistol wrote:

To add to the conversation I as well did not get the Gothic Chair and I did not have it previously from the old Lockwood Showcase. It is the ONE item I still need from the set and I really hope I didnt miss it now for a second time -_-

All the people I've talked to as of yet have said they have not recieved the reward. These people too did not attend the 2011 event so it's not something they had previously. When I went it was around 3:30 pm mountain time, I'm not sure when the servers reset but I'm sure this time is well before it happens. I was only able to enjoy Spun'oween for an hour or so, it froze and kicked me out but I was able to get the reward before this happened. Like I said, seems we were tricked this year Smiley Sad

Message 12 of 17 (211 Views)
Hekseville Citizen
Registered: 12/24/2011
Offline
254 posts
 

Re: Didn't get Hub reward item today?

Nov 1, 2013

I just checked the commerce point from the cauldron just for kicks and the Lock-a-doodle is under the FREE section. Could this be the Halloween reward?

Message 13 of 17 (202 Views)
0 Likes
Fender Bender
Registered: 06/18/2011
Offline
2760 posts
 

Re: Didn't get Hub reward item today?

Nov 1, 2013
My alt account finally got the gothic chair. That was after 9 log in/outs. The gothic table showed up 4 days after I should have got it. I think those missing the chair will eventually get it to post. Spunland changed back to the normal colors at around 8 pm est tonight. The broom LMO is now an unknown. But, the store still has a maze, just in normal colors. Maybe the Space is broken. Since the maze is still in the store, I think it may be an error. I expect the Developer will make good on this.
Posted Image

 
Message 14 of 17 (200 Views)
0 Likes
Fender Bender
Registered: 03/01/2010
Offline
2879 posts
 

Re: Didn't get Hub reward item today?

Nov 1, 2013

I don't think it made it to the US, but keep searching the maze. I had to keep looking for a while and found it.


Thanks Asuka424 for the Signature
Message 15 of 17 (179 Views)
0 Likes
Sackboy
Registered: 12/14/2009
Offline
381 posts
 

Re: Didn't get Hub reward item today?

Nov 1, 2013

ralahinn1 wrote:

I don't think it made it to the US, but keep searching the maze. I had to keep looking for a while and found it.


You found the LMO in the normal, white Store Maze?  That's what it is currently.

 

Message 16 of 17 (175 Views)
0 Likes
Ghost of Sparta
Registered: 11/12/2010
Offline
9504 posts
 

Re: Didn't get Hub reward item today?

Nov 1, 2013
The Broom Broom LMO is not found in the normal white maze in the store FYI. The maze is now a regular addition to Spunland and it was there before Spun O Ween for a few days.
Support Forums
Message 17 of 17 (135 Views)
0 Likes