Reply
Aug 07 2011
By: Morral First Son 8 posts
Offline
Accepted Solution

Receiving UDP packages from server

6 replies 239 views Edited Aug 7, 2011

Hi, I downloaded the code and I'm developing using C#.

Tried the examples included, like PSMoveSharpAR or PSMoveSharpTest but I don't see anything updating, the only thing I could do was sending vibration command to the control, but I don't receive any data.

I also tried using the already implemented protocol PSMoveSharp and used the PSMoveClientThreadedRead and successfully connected to the server, but I still can't get any data from server, like button pressed, accel, speed, etc from the control.

Has somebody made this work??

Thanks

Message 1 of 7 (239 Views)
Reply
0 Likes
First Son
Registered: 06/19/2010
Offline
24 posts
 

Re: Receiving UDP packages from server

Aug 7, 2011

Hi,

I've tried the C# code and got the same problem. Just PAUSE, RUMBLE and CONNECT works. All track information are disabled.

Message 2 of 7 (239 Views)
Reply
0 Likes
Uncharted Territory
Registered: 02/17/2009
Offline
1904 posts
 

Re: Receiving UDP packages from server

Aug 10, 2011
Message 3 of 7 (239 Views)
First Son
Registered: 06/19/2010
Offline
24 posts
 

Re: Receiving UDP packages from server

Aug 10, 2011

Thank you The_7Doom.

That was my problem. The firewall...

Message 4 of 7 (239 Views)
Reply
0 Likes
First Son
Registered: 07/29/2011
Offline
8 posts
 

Re: Receiving UDP packages from server

Aug 10, 2011

Hi,

Thanks for the answer, I had already read that but I didn't remember haha, I think I'm a bit absent lately.

I'm at work now but will test it when I get home.

Thanks again!

Message 5 of 7 (239 Views)
Reply
0 Likes
First Son
Registered: 07/29/2011
Offline
8 posts
 

Re: Receiving UDP packages from server

Aug 11, 2011

Thanks,

It was my firewall, I just made a rule to let pass udp ports and that was it.

Message 6 of 7 (239 Views)
Reply
0 Likes
First Son
Registered: 07/15/2007
Offline
5 posts
 

Re: Receiving UDP packages from server

Aug 13, 2011

Wow, its was all because of the firewall. Thanks!

Message 7 of 7 (239 Views)
Reply
0 Likes