Apr 18 2013
By: Gio1006 First Son 1 posts

Ps3 720p games no longer showning full screen on Sony Bravia TV

[ Edited ]
0 replies 516 views Edited Apr 18, 2013



I hope it helps those having the same problem as me


My Pro Evolution soccer 2013 stopped showning in full screen on my TV. It was now showing in a smaller square in the center of my screen.


I searched many forums for the solution but they all came back to saying that I had to press the wide picture button of my TV remote. That wouldn't do it for me since it showed a stretched-out image of less quality.

I tried  everything, on the TV and on the PS3, unplugged for an hour all devices, changed HDMI cable, upscale bd, removed 720p from my video output settings (to force upscale to 1080p) but it wasn't a manual setting issue.

Later  I noticed that I had no longer the 4 options on the Wide Mode button, but only 3, and it was identified as PC. Therefore I realized how the problem started:

The night before I had my laptop connected to port HDMI2. When I went to bed I unplugged the HDMI2 before turning off my laptop. All my bravia's HDMI ports were now stuck as PC in the Wide Mode.

To fix the problem:
I reconnected my laptop to HDMI2, surfed here , then switched the Bravia's input to HDMI1 (where PS3 is) and Voila!!! Wide mode was not showing "PC", but "HDM1" instead. My 4 wide options were there. And my beloved 720p game was shown fullscreen with the same  quality I used to have.

I just went back to HDMI2, posted this message, turned off the Laptop and only then unplugged HDMI2.

HDMI is a tricky business, it got my tv stuck on PC mode, which cannot upscale 720p


Good luck

Message 1 of 1 (516 Views)