Reply
Feb 15 2009
By: bosh_333 First Son 2 posts
Offline

.MP4 movie plays only sound NO VIDEO! (just a black screen)

3 replies 5509 views Edited Feb 15, 2009

Ok, I have a file that I have copied onto my PS3 HD, its a .Mp4 file...

But when I try to play it on my PS3 I ONLY hear the sound of the movie BUT NO VIDEO..just a black screen for video, here are the specification for the video file (I also have the same problem with the file when I try  to stream it v ia media sharing) PLEASE ANY HELP WOULD BE APPRECIATED!

File name: MOVIE.MP4

H.264/MPEG-4 AVC ((Baseline Media)

with AAC Audio 2 Channel Encoding

Message Edited by bosh_333 on 02-15-2009 09:26 AM
Message Edited by bosh_333 on 02-15-2009 09:27 AM
Message 1 of 4 (5,509 Views)
Reply
0 Likes
First Son
Registered: 02/15/2009
Offline
2 posts
 

Re: .MP4 movie plays only sound NO VIDEO! (just a black screen)

Feb 15, 2009

I was able to solve this problem if I use ps3mediaserver software and then FORCE transcode by pressing the transcode foloder on the ps3 screen instead of the movie itself...so basically by FORCING the transcode..

However, when the file is directly on the ps3 i still experience same problem  

Message 2 of 4 (5,509 Views)
Reply
0 Likes
Last Guardian
Registered: 03/15/2005
Offline
12266 posts
 

Re: .MP4 movie plays only sound NO VIDEO! (just a black screen)

Feb 15, 2009

By forcing the transcoding of the file, the software you are using converts the video on-the-fly to a PS3 comaptible video.  There is something about your source video that is not fully compatible with your console.  We need to know more information about the video such as:

  • Video bitrate
  • Video resolution
  • What was used to encode the video (or the source if you don't know what was used to encode the video)

 

The PS3 is incompatible with the video portion of your file, that is where the problem is.  We could help you if we knew more information about the video portion.

Message 3 of 4 (5,509 Views)
Reply
0 Likes
Fender Bender
Registered: 08/05/2006
Online
4195 posts
 

Re: .MP4 movie plays only sound NO VIDEO! (just a black screen)

Feb 16, 2009

Sounds like just a crap encoder that does not know what its doing or is just got a buggy version of X264 library.

If the H264 profile flags are set wrong this results in a black screen when played back.

The PS3 will just not SYNC to the video stream resulting in a blank screen. using base line profile and trying to use the features of Main or high profile, setting H264 level 2.2  and not level 3.0 for example will trigger this. 

Its a known problem with X264 not sticking to H264 profiles...  

Message Edited by GraphiteGB on 02-16-2009 01:23 AM

snapshot6.png

Message 4 of 4 (5,509 Views)
Reply
0 Likes