Jan 02 2011
By: Donny_Lurch First Son 2 posts

GoW1 won't recognize R2 button

1 replies 356 views Edited Jan 2, 2011

I just bought a refurbished PS3 with a brand new, shrink-wrapped copy of GoW Collection. I just put the game in for the first time, and now three times in a row (after both restarting the game and then the entire console), I cannot progress past the first tutorial on the Aegean Sea. I kill the zombies, it tells me I need to press R2 to open the hatch, and nothing happens.

I am aware that I need to repeatedly tap the button, but I've done this for upwards of 15 seconds and Kratos has yet to do so much as reach for the handle. This kind of ruins my whole night if I can't fix this problem immediately, but any help from whoever is around whenever to supply it would be greatly appreciated.

Again, I'm a new PS3 owner, so if there is some kind of debug I can run, please explain to me how to do so. I don't think I should need to debug an out-of-the-box unit, but whatever works. I have tested the R2 button on the text keypad, using it to cycle through character sets, and the button works fine. My problem clearly lies with GoW Collection.

Message 1 of 2 (356 Views)
First Son
Registered: 01/02/2011
2 posts

Re: GoW1 won't recognize R2 button

Jan 2, 2011

Problem solved! I returned the game, had the same issue, but also found that my R2 button would not work in the internet browser. I traded for a new controller and now it works. Huzzah!

I would not say "never buy refurbished," but beware. Also keep in mind that if your refurb controller does come faulty, you can take it back to Gamestop and they will replace it (assuming you bought it there in the first place).

Message 2 of 2 (356 Views)